Saturday 18th April 2020

Portal storage.campbellcloud.io is experiencing issues

April 18 02:16 AM MST

Resolved - Performance issues have been resolved.

April 18 12:37 AM MST

Investigating - We are investigating performance issues with storage.campbellcloud.io. All other services are reporting normally at this time.