Monday 4th May 2020

Portal storage.campbellcloud.io is experiencing issues

May 4 3:31 PM MST

Resolved - Performance issues have been resolved.

May 4 10:16 AM MST

Investigating - We are investigating performance issues with storage.campbellcloud.io. All other services are reporting normally at this time.